Advisories


   openSUSE Security Update: Security update for nextcloud-desktop
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0577-1
Rating:             important
References:         #1184770 
Cross-References:   CVE-2021-22879
CVSS scores:
                    CVE-2021-22879 (SUSE): 6.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for nextcloud-desktop fixes the following issues:

   nextcloud-desktop was updated to 3.1.3:

   - desktop#2884 [stable-3.1] Add support for Hirsute
   - desktop#2920 [stable-3.1] Validate sensitive URLs to onle allow http(s)
     schemes.
   - desktop#2926 [stable-3.1] Validate the providers ssl certificate
   - desktop#2939 Bump release to 3.1.3

   This also fix security issues:

   - (boo#1184770, CVE-2021-22879, NC-SA-2021-008 , CWE-99)

     Nextcloud Desktop Client prior to 3.1.3 is vulnerable to resource
   injection by way of missing validation of URLs, allowing a malicious
   server to execute remote commands. User interaction is needed for
   exploitation.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-577=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      libnextcloudsync-devel-3.1.3-lp152.2.6.1
      libnextcloudsync0-3.1.3-lp152.2.6.1
      libnextcloudsync0-debuginfo-3.1.3-lp152.2.6.1
      nextcloud-desktop-3.1.3-lp152.2.6.1
      nextcloud-desktop-debuginfo-3.1.3-lp152.2.6.1
      nextcloud-desktop-debugsource-3.1.3-lp152.2.6.1
      nextcloud-desktop-dolphin-3.1.3-lp152.2.6.1
      nextcloud-desktop-dolphin-debuginfo-3.1.3-lp152.2.6.1

   - openSUSE Leap 15.2 (noarch):

      caja-extension-nextcloud-3.1.3-lp152.2.6.1
      nautilus-extension-nextcloud-3.1.3-lp152.2.6.1
      nemo-extension-nextcloud-3.1.3-lp152.2.6.1
      nextcloud-desktop-doc-3.1.3-lp152.2.6.1
      nextcloud-desktop-lang-3.1.3-lp152.2.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-22879.html
   https://bugzilla.suse.com/1184770

Warning: getimagesize(/images/distros-large/opensuse-large.png): failed to open stream: No such file or directory in /var/www/webstage.linuxsecurity.com-443/html/templates/newsberg/html/com_content/article/default.php on line 107

Warning: Division by zero in /var/www/webstage.linuxsecurity.com-443/html/templates/newsberg/html/com_content/article/default.php on line 110

openSUSE: 2021:0577-1 important: nextcloud-desktop

An update that fixes one vulnerability is now available.

   openSUSE Security Update: Security update for nextcloud-desktop
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0577-1
Rating:             important
References:         #1184770 
Cross-References:   CVE-2021-22879
CVSS scores:
                    CVE-2021-22879 (SUSE): 6.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for nextcloud-desktop fixes the following issues:

   nextcloud-desktop was updated to 3.1.3:

   - desktop#2884 [stable-3.1] Add support for Hirsute
   - desktop#2920 [stable-3.1] Validate sensitive URLs to onle allow http(s)
     schemes.
   - desktop#2926 [stable-3.1] Validate the providers ssl certificate
   - desktop#2939 Bump release to 3.1.3

   This also fix security issues:

   - (boo#1184770, CVE-2021-22879, NC-SA-2021-008 , CWE-99)

     Nextcloud Desktop Client prior to 3.1.3 is vulnerable to resource
   injection by way of missing validation of URLs, allowing a malicious
   server to execute remote commands. User interaction is needed for
   exploitation.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-577=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      libnextcloudsync-devel-3.1.3-lp152.2.6.1
      libnextcloudsync0-3.1.3-lp152.2.6.1
      libnextcloudsync0-debuginfo-3.1.3-lp152.2.6.1
      nextcloud-desktop-3.1.3-lp152.2.6.1
      nextcloud-desktop-debuginfo-3.1.3-lp152.2.6.1
      nextcloud-desktop-debugsource-3.1.3-lp152.2.6.1
      nextcloud-desktop-dolphin-3.1.3-lp152.2.6.1
      nextcloud-desktop-dolphin-debuginfo-3.1.3-lp152.2.6.1

   - openSUSE Leap 15.2 (noarch):

      caja-extension-nextcloud-3.1.3-lp152.2.6.1
      nautilus-extension-nextcloud-3.1.3-lp152.2.6.1
      nemo-extension-nextcloud-3.1.3-lp152.2.6.1
      nextcloud-desktop-doc-3.1.3-lp152.2.6.1
      nextcloud-desktop-lang-3.1.3-lp152.2.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-22879.html
   https://bugzilla.suse.com/1184770

Print  

openSUSE: 2021:0577-1 important: nextcloud-desktop

April 19, 2021
An update that fixes one vulnerability is now available.

Summary

nextcloud-desktop was updated to 3.1.3: - desktop#2884 [stable-3.1] Add support for Hirsute - desktop#2920 [stable-3.1] Validate sensitive URLs to onle allow http(s) schemes. - desktop#2926 [stable-3.1] Validate the providers ssl certificate - desktop#2939 Bump release to 3.1.3 This also fix security issues: - (boo#1184770, CVE-2021-22879, NC-SA-2021-008 , CWE-99) Nextcloud Desktop Client prior to 3.1.3 is vulnerable to resource injection by way of missing validation of URLs, allowing a malicious server to execute remote commands. User interaction is needed for exploitation.

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-577=1

List

Package List: - openSUSE Leap 15.2 (x86_64): libnextcloudsync-devel-3.1.3-lp152.2.6.1 libnextcloudsync0-3.1.3-lp152.2.6.1 libnextcloudsync0-debuginfo-3.1.3-lp152.2.6.1 nextcloud-desktop-3.1.3-lp152.2.6.1 nextcloud-desktop-debuginfo-3.1.3-lp152.2.6.1 nextcloud-desktop-debugsource-3.1.3-lp152.2.6.1 nextcloud-desktop-dolphin-3.1.3-lp152.2.6.1 nextcloud-desktop-dolphin-debuginfo-3.1.3-lp152.2.6.1 - openSUSE Leap 15.2 (noarch): caja-extension-nextcloud-3.1.3-lp152.2.6.1 nautilus-extension-nextcloud-3.1.3-lp152.2.6.1 nemo-extension-nextcloud-3.1.3-lp152.2.6.1 nextcloud-desktop-doc-3.1.3-lp152.2.6.1 nextcloud-desktop-lang-3.1.3-lp152.2.6.1
Severity
______________________________________________________________________________
Announcement ID: openSUSE-SU-2021:0577-1
Rating: important
References: #1184770
Cross-References: CVE-2021-22879
CVSS scores:
CVE-2021-22879 (SUSE): 6.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Affected Products:
openSUSE Leap 15.2

References

References: https://www.suse.com/security/cve/CVE-2021-22879.html https://bugzilla.suse.com/1184770

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.