Advisories


   openSUSE Security Update: Security update for postsrsd
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0669-1
Rating:             moderate
References:         #1180251 
Cross-References:   CVE-2020-35573
Affected Products:
                    openSUSE Backports SLE-15-SP2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for postsrsd fixes the following issues:

   Update to release 1.11 [boo#1180251]

   * Drop group privileges as well as user privileges
   * Fixed: The subprocess that talks to Postfix could be caused to hang with
     a very long email address. [CVE-2020-35573]

   Update to release 1.6

   * Fix endianness issue with SHA-1 implementation
   * Add dual stack support
   * Make SRS separator configurable

   This update was imported from the openSUSE:Leap:15.2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP2:

      zypper in -t patch openSUSE-2021-669=1



Package List:

   - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64):

      postsrsd-1.11-bp152.4.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-35573.html
   https://bugzilla.suse.com/1180251

Warning: getimagesize(/images/distros-large/opensuse-large.png): failed to open stream: No such file or directory in /var/www/webstage.linuxsecurity.com-443/html/templates/newsberg/html/com_content/article/default.php on line 107

Warning: Division by zero in /var/www/webstage.linuxsecurity.com-443/html/templates/newsberg/html/com_content/article/default.php on line 110

openSUSE: 2021:0669-1 moderate: postsrsd

An update that fixes one vulnerability is now available.

   openSUSE Security Update: Security update for postsrsd
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0669-1
Rating:             moderate
References:         #1180251 
Cross-References:   CVE-2020-35573
Affected Products:
                    openSUSE Backports SLE-15-SP2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for postsrsd fixes the following issues:

   Update to release 1.11 [boo#1180251]

   * Drop group privileges as well as user privileges
   * Fixed: The subprocess that talks to Postfix could be caused to hang with
     a very long email address. [CVE-2020-35573]

   Update to release 1.6

   * Fix endianness issue with SHA-1 implementation
   * Add dual stack support
   * Make SRS separator configurable

   This update was imported from the openSUSE:Leap:15.2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP2:

      zypper in -t patch openSUSE-2021-669=1



Package List:

   - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64):

      postsrsd-1.11-bp152.4.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-35573.html
   https://bugzilla.suse.com/1180251

Print  

openSUSE: 2021:0669-1 moderate: postsrsd

May 4, 2021
An update that fixes one vulnerability is now available.

Summary

Update to release 1.11 [boo#1180251] * Drop group privileges as well as user privileges * Fixed: The subprocess that talks to Postfix could be caused to hang with a very long email address. [CVE-2020-35573] Update to release 1.6 * Fix endianness issue with SHA-1 implementation * Add dual stack support * Make SRS separator configurable This update was imported from the openSUSE:Leap:15.2:Update update project.

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP2: zypper in -t patch openSUSE-2021-669=1

List

Package List: - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64): postsrsd-1.11-bp152.4.3.1
Severity
______________________________________________________________________________
Announcement ID: openSUSE-SU-2021:0669-1
Rating: moderate
References: #1180251
Cross-References: CVE-2020-35573
Affected Products:
openSUSE Backports SLE-15-SP2

References

References: https://www.suse.com/security/cve/CVE-2020-35573.html https://bugzilla.suse.com/1180251

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.