Advisories


   openSUSE Security Update: Security update for pcre
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3529-1
Rating:             moderate
References:         #1172973 #1172974 
Cross-References:   CVE-2019-20838 CVE-2020-14155
CVSS scores:
                    CVE-2019-20838 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2019-20838 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2020-14155 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2020-14155 (SUSE): 6.2 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for pcre fixes the following issues:

   Update pcre to version 8.45:

   - CVE-2020-14155: Fixed integer overflow via a large number after a '(?C'
     substring (bsc#1172974).
   - CVE-2019-20838: Fixed buffer over-read in JIT compiler (bsc#1172973)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3529=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libpcre1-8.45-20.10.1
      libpcre1-debuginfo-8.45-20.10.1
      libpcre16-0-8.45-20.10.1
      libpcre16-0-debuginfo-8.45-20.10.1
      libpcrecpp0-8.45-20.10.1
      libpcrecpp0-debuginfo-8.45-20.10.1
      libpcreposix0-8.45-20.10.1
      libpcreposix0-debuginfo-8.45-20.10.1
      pcre-debugsource-8.45-20.10.1
      pcre-devel-8.45-20.10.1
      pcre-devel-static-8.45-20.10.1
      pcre-tools-8.45-20.10.1
      pcre-tools-debuginfo-8.45-20.10.1

   - openSUSE Leap 15.3 (noarch):

      pcre-doc-8.45-20.10.1

   - openSUSE Leap 15.3 (x86_64):

      libpcre1-32bit-8.45-20.10.1
      libpcre1-32bit-debuginfo-8.45-20.10.1
      libpcre16-0-32bit-8.45-20.10.1
      libpcre16-0-32bit-debuginfo-8.45-20.10.1
      libpcrecpp0-32bit-8.45-20.10.1
      libpcrecpp0-32bit-debuginfo-8.45-20.10.1
      libpcreposix0-32bit-8.45-20.10.1
      libpcreposix0-32bit-debuginfo-8.45-20.10.1


References:

   https://www.suse.com/security/cve/CVE-2019-20838.html
   https://www.suse.com/security/cve/CVE-2020-14155.html
   https://bugzilla.suse.com/1172973
   https://bugzilla.suse.com/1172974

openSUSE: 2021:3529-1 moderate: pcre

October 27, 2021
An update that fixes two vulnerabilities is now available

Description

This update for pcre fixes the following issues: Update pcre to version 8.45: - CVE-2020-14155: Fixed integer overflow via a large number after a '(?C' substring (bsc#1172974). - CVE-2019-20838: Fixed buffer over-read in JIT compiler (bsc#1172973)

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-3529=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libpcre1-8.45-20.10.1 libpcre1-debuginfo-8.45-20.10.1 libpcre16-0-8.45-20.10.1 libpcre16-0-debuginfo-8.45-20.10.1 libpcrecpp0-8.45-20.10.1 libpcrecpp0-debuginfo-8.45-20.10.1 libpcreposix0-8.45-20.10.1 libpcreposix0-debuginfo-8.45-20.10.1 pcre-debugsource-8.45-20.10.1 pcre-devel-8.45-20.10.1 pcre-devel-static-8.45-20.10.1 pcre-tools-8.45-20.10.1 pcre-tools-debuginfo-8.45-20.10.1 - openSUSE Leap 15.3 (noarch): pcre-doc-8.45-20.10.1 - openSUSE Leap 15.3 (x86_64): libpcre1-32bit-8.45-20.10.1 libpcre1-32bit-debuginfo-8.45-20.10.1 libpcre16-0-32bit-8.45-20.10.1 libpcre16-0-32bit-debuginfo-8.45-20.10.1 libpcrecpp0-32bit-8.45-20.10.1 libpcrecpp0-32bit-debuginfo-8.45-20.10.1 libpcreposix0-32bit-8.45-20.10.1 libpcreposix0-32bit-debuginfo-8.45-20.10.1

Severity
Announcement ID: openSUSE-SU-2021:3529-1
Rating: moderate
References: #1172973 #1172974
Cross-References: CVE-2019-20838 CVE-2020-14155
CVSS scores:
CVE-2019-20838 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2019-20838 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2020-14155 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2020-14155 (SUSE): 6.2 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Affected Products:
openSUSE Leap 15.3

References

https://www.suse.com/security/cve/CVE-2019-20838.html https://www.suse.com/security/cve/CVE-2020-14155.html https://bugzilla.suse.com/1172973 https://bugzilla.suse.com/1172974

Related News

Google Ad Placeholder
Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ ? ]

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.