Advisories


   openSUSE Security Update: Security update for ruby2.5
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3838-1
Rating:             important
References:         #1188160 #1188161 #1190375 
Cross-References:   CVE-2021-31799 CVE-2021-31810 CVE-2021-32066
                   
CVSS scores:
                    CVE-2021-31799 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-31810 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
                    CVE-2021-32066 (SUSE): 7.4 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for ruby2.5 fixes the following issues:

   - CVE-2021-31799: Fixed Command injection vulnerability in RDoc
     (bsc#1190375).
   - CVE-2021-31810: Fixed trusting FTP PASV responses vulnerability in
     Net:FTP (bsc#1188161).
   - CVE-2021-32066: Fixed StartTLS stripping vulnerability in Net:IMAP
     (bsc#1188160).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3838=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libruby2_5-2_5-2.5.9-4.20.1
      libruby2_5-2_5-debuginfo-2.5.9-4.20.1
      ruby2.5-2.5.9-4.20.1
      ruby2.5-debuginfo-2.5.9-4.20.1
      ruby2.5-debugsource-2.5.9-4.20.1
      ruby2.5-devel-2.5.9-4.20.1
      ruby2.5-devel-extra-2.5.9-4.20.1
      ruby2.5-doc-2.5.9-4.20.1
      ruby2.5-stdlib-2.5.9-4.20.1
      ruby2.5-stdlib-debuginfo-2.5.9-4.20.1

   - openSUSE Leap 15.3 (noarch):

      ruby2.5-doc-ri-2.5.9-4.20.1


References:

   https://www.suse.com/security/cve/CVE-2021-31799.html
   https://www.suse.com/security/cve/CVE-2021-31810.html
   https://www.suse.com/security/cve/CVE-2021-32066.html
   https://bugzilla.suse.com/1188160
   https://bugzilla.suse.com/1188161
   https://bugzilla.suse.com/1190375

openSUSE: 2021:3838-1 important: ruby2.5

December 1, 2021
An update that fixes three vulnerabilities is now available

Description

This update for ruby2.5 fixes the following issues: - CVE-2021-31799: Fixed Command injection vulnerability in RDoc (bsc#1190375). - CVE-2021-31810: Fixed trusting FTP PASV responses vulnerability in Net:FTP (bsc#1188161). - CVE-2021-32066: Fixed StartTLS stripping vulnerability in Net:IMAP (bsc#1188160).

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-3838=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libruby2_5-2_5-2.5.9-4.20.1 libruby2_5-2_5-debuginfo-2.5.9-4.20.1 ruby2.5-2.5.9-4.20.1 ruby2.5-debuginfo-2.5.9-4.20.1 ruby2.5-debugsource-2.5.9-4.20.1 ruby2.5-devel-2.5.9-4.20.1 ruby2.5-devel-extra-2.5.9-4.20.1 ruby2.5-doc-2.5.9-4.20.1 ruby2.5-stdlib-2.5.9-4.20.1 ruby2.5-stdlib-debuginfo-2.5.9-4.20.1 - openSUSE Leap 15.3 (noarch): ruby2.5-doc-ri-2.5.9-4.20.1

Severity
Announcement ID: openSUSE-SU-2021:3838-1
Rating: important
References: #1188160 #1188161 #1190375
Cross-References: CVE-2021-31799 CVE-2021-31810 CVE-2021-32066
CVSS scores: CVE-2021-31799 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVE-2021-31810 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVE-2021-32066 (SUSE): 7.4 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Affected Products: openSUSE Leap 15.3 .

References

https://www.suse.com/security/cve/CVE-2021-31799.html https://www.suse.com/security/cve/CVE-2021-31810.html https://www.suse.com/security/cve/CVE-2021-32066.html https://bugzilla.suse.com/1188160 https://bugzilla.suse.com/1188161 https://bugzilla.suse.com/1190375

Related News

Ad
Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ ? ]

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.