Advisories


- -------------------------------------------------------------------------
Debian Security Advisory DSA-4907-1                   security@debian.org
https://www.debian.org/security/                       Sebastien Delafond
April 29, 2021                        https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : composer
CVE ID         : CVE-2021-29472

It was discovered that composer, a dependency manager for PHP, did not
properly sanitize Mercurial URLs, which could lead to arbitrary code
execution.

For the stable distribution (buster), this problem has been fixed in
version 1.8.4-1+deb10u1.

We recommend that you upgrade your composer packages.

For the detailed security status of composer please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/composer

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Warning: getimagesize(/images/distros-large/debian-large.png): failed to open stream: No such file or directory in /var/www/webstage.linuxsecurity.com-443/html/templates/newsberg/html/com_content/article/default.php on line 107

Warning: Division by zero in /var/www/webstage.linuxsecurity.com-443/html/templates/newsberg/html/com_content/article/default.php on line 110

Debian: DSA-4907-1: composer security update

It was discovered that composer, a dependency manager for PHP, did not properly sanitize Mercurial URLs, which could lead to arbitrary code execution.

- -------------------------------------------------------------------------
Debian Security Advisory DSA-4907-1                   This email address is being protected from spambots. You need JavaScript enabled to view it.
https://www.debian.org/security/                       Sebastien Delafond
April 29, 2021                        https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : composer
CVE ID         : CVE-2021-29472

It was discovered that composer, a dependency manager for PHP, did not
properly sanitize Mercurial URLs, which could lead to arbitrary code
execution.

For the stable distribution (buster), this problem has been fixed in
version 1.8.4-1+deb10u1.

We recommend that you upgrade your composer packages.

For the detailed security status of composer please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/composer

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: This email address is being protected from spambots. You need JavaScript enabled to view it.

Print  

Warning: Invalid argument supplied for foreach() in /var/www/webstage.linuxsecurity.com-443/html/lsadvisories.php on line 25

Debian: DSA-4907-1: composer security update

April 29, 2021
It was discovered that composer, a dependency manager for PHP, did not properly sanitize Mercurial URLs, which could lead to arbitrary code execution.

Summary

Debian Security Advisory DSA-4907-1 security@debian.org https://www.debian.org/security/ Sebastien Delafond April 29, 2021 https://www.debian.org/security/faq

It was discovered that composer, a dependency manager for PHP, did not properly sanitize Mercurial URLs, which could lead to arbitrary code execution.

For the stable distribution (buster), this problem has been fixed in version 1.8.4-1+deb10u1.

We recommend that you upgrade your composer packages.

For the detailed security status of composer please refer to its security tracker page at: https://security-tracker.debian.org/tracker/composer

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Severity
Package : composer
CVE ID : CVE-2021-29472

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.